RMAN Catalog requires Enterprise Edition (EE)
since Oracle Database 12.1.0.2

오라클 데이터베이스 12.1.0.2 버전부터는 RMAN Recovery catalog를 위해서는 EE 버전이 필요하다고 합니다.
이유는 RMAN Recovery catalog에서 Partition옵션을 요구하기 때문입니다.  Partition 옵션은 SE버전에는 없으며 EE 버전에서만 사용 가능한 옵션 입니다.
그렇다고 EE 버전을 무조건 구매할 필요는 없으며 오라클 라이선스 정책에 따라 RMAN Recovery catalog, EM Cloud Control, AWR 저장, Grid 관리 Repository 등의 정보를 싱글 인스턴스에는 무료로 저장할 수 있습니다.
다만 이 인스턴스에는 다른 서비스를 얹는다거나 하면 라이선스 위반이 되기 때문에 주의 하여야 합니다.

자세한 12.1 버전의 라이선스 정보는 다음 링크에 자세히 나와 있습니다.
http://docs.oracle.com/database/121/DBLIC/editions.htm#DBLIC119

실제로 12.1 버전으로 RMAN Recovery catalog를 upgrade하기 위해서 upgrade catalog 명령어를 수행하면 다음과 같은 오류가 발생한다고 합니다.

RMAN> upgrade catalog;

error creating create_deleted_object_seq
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-06004: ORACLE error from recovery catalog database:
ORA-00439: feature not enabled: Partitioning




추가로 기존에 쓰던 RMAN Recovery catalog를 upgrade 하기 위해서는 아래 사항이 필요합니다.


• RMAN catalog를 호스팅하는 데이터베이스의 버전은 12.1.0.2로 시작
• UTL_HTTP & DBMS_LOB Package
• Partition 옵션이 설치 되어있는 EE 버전의 Database



사업자 정보 표시
(주)블루원 | 김홍태 | 서울특별시 용산구 원효로 4가 135 금홍 2빌딩 | 사업자 등록번호 : 106-86-76684 | TEL : 02-3272-7200 | Mail : support_ora@blueone.co.kr | 사이버몰의 이용약관 바로가기

+ Recent posts